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MANAGING YOUR JOOMLA WEBSITE 
 
What is Joomla?   
Joomla is a content management system (CMS) that provides a user-friendly interface for managing web content 
and other features. As an open-source solution, it is freely available to everyone. Third Sun has a specific and 
optimized implementation for Joomla that is customized for our clients, so our training is also customized to help 
clients manage things without hunting through support forums and outside tools. 
 
Note: When using the Joomla management tools (i.e. logged into the backend and trying to edit and/or create 
content), please use Firefox or Chrome (both free browsers).  
 
Support Requests 
Third Sun wants you to be successful managing your website, and we expect that you will have questions or needs 
that arise on occasion. To serve all of our clients’ needs efficiently, we prefer you to email support@thirdsun.com 
because we usually need to be in front of a computer with your website pulled up to help you, and this ensures you 
get speedy help from the team member best suited to help you. When you submit your question or request, 
consider also sending the following:  
  

• Your question or need stated clearly  
• Link of the page you are referencing (if applicable)  
• Screenshot of what you are seeing (or not seeing and if applicable)  

  
When we have all the details about an issue, we can help you more quickly. For urgent issues (site downtime or 
other occurrences), email is still best. For more resources and Help Docs, go to thirdsun.com/help-docs  
 
Training Guide 
To access a digital version of this document, navigate to the backend Control Panel of your Joomla website. Select 
“Style Guide” and the file will be under the heading “Do you need more help?” 
  
Logging In to Backend 
Open your browser to saltlakeactingcompany.org/administrator and bookmark for future use. Login with your 
current username and password. If you do not have one, one of your administrators can make you a user account 
by logging in and following instructions below under User Manager.  
  
Backend Navigation 
The backend of Joomla navigates like a website itself. You can access Menus, Content, Components, Extensions, 
etc. Most commonly used will be Items/K2 and Components area. 

  
In the top righthand corner of the backend, there’s a shortcut to the frontend of the 
site.  
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 User Manager: Add new users or disable who can manage the site by clicking the Users button on 
your dashboard. Click the “New” icon (top right of the page) and complete information on the left 
(no need to do anything on the right as these will just default to proper settings). Then toggle to 
the “Assigned User Groups” tab and assign a trusted user at the “Administrator” level. Don’t 
delete users, this can cause issues on your site. Only disable past users. Each user needs a distinct 

email address, i.e. you can’t use the same email for everyone to use as a generic user like “Admin”. 
 
Menu Manager 
Your website should not require frequent changes or additions to the menu navigation (it isn’t a good practice for 
your returning site visitors because they should be able to depend on the organization of your website to be 
relatively consistent). To access the Menu navigation and understand its structure, go to Menus > Main Menu. 
From here, you can add or delete options, but setting up menu items requires having already created the content 
and knowing how to link that content. See our Help Docs on Menus for more details, and if you need slight 
adjustments (i.e. adding an item or deactivating an item) you can contact support@thirdsun.com with your request. 
  

 Homepage and Modules 
Many components throughout your site, including homepage tiers, sidebars, and footers are 
controlled in the Module Manager, which you can view by going to Extensions > Module Manager.  
Modules are custom-tailored to your website, so do not edit or delete modules unless you know 
what you are doing.  

Edit the Language on Your Homepage 
Remember: your homepage content is not in Items. Start with finding the respective module (color coded with a 
blue square), i.e. Banner, and then change the text. We recommend being very cautious with homepage edits, like 
adding images or too much formatting as it can interfere with the design. We are happy to help with changes, for 
assistance finding or editing a module, please email support@thirdsun.com or find a “Help Docs” tutorial at 
thirdsun.com/help-docs/editing-modules  
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Adding or Editing Site Content 
 K2 — is a component that allows for additional features in the 
content management system, Joomla. 
Structure — Your website is organized by Categories and Items.   
Categories — main groups you organize items into.   
Items — individual pieces of content that work often like pages 
on your website.  

 
Creating or Editing an Item 
 
Step 1: Navigate to K2 via the top menu or navigate to All Items from your Control Panel 

• Once you are in the “Items” area, you will see a list of existing items. 
• From the K2 Items list, filter them by using “Select category” to view items in a particular category. 

  

 
 
Step 2: Select your item or create a new one.  

• Edit an existing K2 Item by clicking on the title.   
• Create a new K2 Item by clicking “+ New” green button in the top right.   

  
Step 3: Give your new K2 Item a good Title. Assign it to the proper Category according to your site’s organization. 
The “Title alias” will auto-complete when you save, so you don’t need to add it. 
  
Step 4: Create your text in the text editor either by pasting from a document or typing directly in the editor area. 
For headings, Use the dropdown that says “Paragraph” and select “Heading 2” or “Heading 3.” And so on. 
 
Step 5: This is optional depending on how your site and pages are set up. Some items need a main images. To 
add a main image, Click on the Image tab, then Choose File and select an image. Avoid extremely large images 
(over 1-2mb.) or poor quality/grainy images. Aim for 200-300kb sized image files. Photos may also be inserted into 
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content using the “Insert/Edit Image” icon (more info below). Most of your main images are 1600x900 pixels, 
current show pages (poster layout) are 2000x2800. 
  
REMEMBER: Always click Save or Save & Close for your changes (click Cancel if you do not want your changes to 
take effect). Please note that if you delete or unpublish a K2 item connected to a Menu item, you will need to 
reassign that Menu item to a published item or retire it (email support@thirdsun.com if you need help). 
 
The Basics: Maintaining your website is easy, here are some useful tips:    

• Keep your content clean! Write compelling, concise, and clear content. Avoid ALL CAPS for consistency. 
• Give your items/articles an appropriate title and assign to correct category. Don’t add title alias. 
• Headings - To create headings (and keep things consistent in the site), highlight the text to be made a 

heading and under Format, start with Heading 2 then Heading 3 (Heading 1 is usually used already by the 
page title). You can preview your headings from the Style Guide shortcut in your dashboard. Be consistent 
and work from h2 down for best accessibility. Don’t add links to headings. 

• Line break (but not hard return) - Click Shift and then Enter to get a line break. In the site’s code this differs 
from a hard return which will create a paragraph space between lines. 

• Bullets or Number Lists - Enter your text with hard returns between the lines you want to bullet point (or 
number). Select the lines and click the Bullet List or Numbered List icons. 

• Bold, Underline, or Italics - Use these sparingly for impact, avoid underlines as they tend to look like links 
and are bad for accessibility. 

• Alignment – Avoid centering text whenever possible for best accessibility/useability best practices. Also 
avoid justified alignment. Left-aligned is best. 

 
Adding Links, Images, and More to Your Item’s Content 
 

• Insert/Edit Link: Highlight the text (or image) to link 

and then click link icon to open link manager.  

• To add a link to another page on your site, use the link 

manager, select your page by clicking Main Menu folder and 

finding the correct page, (don’t adjust the Target) then click 

Insert. If you can’t find it under Main Menu look under K2 

Categories & Items.  

• To add a link to a page that’s not on your site, enter the URL 

(complete with https:// ), change the Target “Open in new 

window.” Then click Insert. 

• Button Style Links: Create a link button by following the link 

steps above, but before clicking Insert go to the “Advanced” 

tab and type ‘btn’ in the “Classes” field. Then Insert.  

• NOTE: Don’t add links to headings. 
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 Insert File Link: To insert a document for users to download (pdf, doc, xls, jpg) into your K2 Item, write a 
phrase (i.e. Download this file) and highlight. Click the Insert File Link icon. Select an existing or upload a 

new document by clicking the Upload icon (arrow pointing up on the right side of the File Manager pop-up). Once 
uploaded, select the file to link.  
 

Insert/Edit Image: To insert an image directly in the content, click your cursor in the spot where you want the 
photo to appear and click the Insert/Edit Image icon. Upload an image by clicking “Upload” in the Image 

Manager Extended pop-up. Once uploaded, click on the file and so the URL line populates. Add alt text if desired 
(for best accessibility). You can align right or left and set a margin (like 5 pixels) or have them be full width (this is 
often best these days with mobile phones – as long as the photos are not vertical). For full width, have the width 
dimension be “100%” and delete the height or leave blank.  
 
Insert a Video: First, upload the video to the platform of your choice, this is ideal so that the site isn’t hosting the 
video file itself. then locate the video ID: 

• On Youtube videos this is after “V=” in the URL, i.e.  https://www.youtube.com/watch?v=dQw4w9WgXcQ 
so the Video ID is “dQw4w9WgXcQ".  

• On Vimeo the Video ID comes after “vimeo.com/".  
Insert in the content into the code found under “Short Codes” in the editor in place of “videoID” . i.e. 
{youtube}videoID{/youtube} (same for Vimeo or Soundcloud using {vimeo}videoID{/vimeo}, etc.). 
 

Insert Columns: To insert columns click the columns icon and then select the number of columns and width 
– we don’t suggest more than 3 for best mobile experience.  
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News Feed 
Add new items to the Updates category to have them published as posts on the site. They’ll automatically 
show on the homepage news feed and in the Updates section in the Latest News dropdown. Come up with a 
good title, don’t fill in the Title-alias. Follow the best practices outlined above for formatting your text, i.e. use 
consistent headings, no caps or underlines, etc. Add in an image if you’d like, most of your main images are 
1600x900 pixels but this isn’t strict. Portrait-orientation images may not crop correctly on the homepage. 

 
If you no longer want a post to be published, click on the Published toggle in the Item. If you wish to make 
changes to the publishing date of an item, like a blog post (i.e. have it unpublish or publish on a specific date), 
go to the “Publishing & Metadata” tab in the item (top of page between “Basic” and “Display Settings”), 
under “Creation Date” select the date you’d like the item to show as being published. If you want it to stop 
appearing at a certain date, write in a “Finish Date”. Here you can also add in optional Metadata – the 
“Description” will create a description for search engines to show (by default they pull a snippet of the first 
~155 characters on the page) and that’s what comes up in a search result preview. You can also add 
“Keywords” for search engines here. 
 
Reminder that all links to other sites should Open in New Tab. 
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Adding a Gallery 
 
Galleries are used on the Show pages for your site and can be used elsewhere like blogs as well. 
To add a gallery to a Show, click Image Galleries from your dashboard. Then click the green 
“New” button to add a new gallery. Give it a title (likely the show name) and you can either drag 
and drop images or click the green “Add Images” button. After they’re uploaded, you can add 

text for alt-text in the box underneath each photo. To delete an image, click the X in the top right corner of the 
image. Save & Close when you’re finished. 
Once your gallery is created note the ID #. This will be used to add it to the Show page – steps on next page. 
 

 
 

To add a gallery to a blog (or other non-show page) 
From your Item, click the Showtime Image Gallery button below the content editor. From there you can drag and 
drop images or click Use Existing to insert an existing gallery. You can add image titles (this will auto-create the alt-
text.) When finished click Save & Insert. 
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Adding or Editing Show Pages 
Show pages are added in the category for the current season, i.e. “2021-2022 Season”.  

• To create a new show, click “New” then add in Title – don’t need to add title alias. In the content area, 

you’ll add in the brief important details you want shown in the homepage thumbnail for the show, then 

insert a “Read More” break and below that will have the rest of the info that will be on the show page 

under “Description”.  

 
 

• To add in Cast – first each cast member needs an Item set up in the ‘SLAC Actor Library’ Category. Moving 

Forward, we HIGHLY recommend editing their existing Item instead of adding a new item. I.e. it would be 

“Colleen Baum” instead of “Colleen Baum as …” and it would just be updated for each show she’s in – this 

means the existing pages with that same item would have the same info, so don’t make the language 

show-specific, make it actor-specific. Then in the Show page scroll below the content area to K2 Link Item 

and find the Item for each respective cast member. Note: if you ever have spare time, you can go through 

archive and replace old cast items with newest one and delete the old ones from the Library. If you delete 

them without adding to the archive first, they will no longer show on old show pages. 

• Add in a main Image on the “Image tab”. The images for the current season are 2000x2800. 

•  To add in the information that shows under “Details” go to the “Extra Fields” tab.  

o Fill in relevant info – you can leave blanks for missing info, and it won’t show the field on the Show 

page. Ignore the field with an * – it’s in use on old shows so we can’t delete it, we’d lose old info.  

o To add the gallery, copy and paste the code from the field, {showtime X} and replace the X with the 

ID # from the gallery (see steps above for creating a gallery). I.e. for Four Women… you’d put in the 

field: {showtime 2} 
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Other Notes on Your Site 
 

Not Seeing Your Edits? 
The most common culprit when you’re not seeing your edits on the front end of the site is your browser’s cache. 
First, make sure you’re refreshing the page on the front end. Then, try clearing your browser’s cache. More notes 
on this here: https://thirdsun.com/help-docs/edit-items-and-categories/why-aren-t-my-changes-showing-up 

 
To Create a Custom URL for Your Site 
Sometimes it’s handy to have a short URL for easy linking and reference – i.e. Saltlakeactingcompany.org/egress 
To create these short URLs, you’d set them up as a hidden menu. Instructions can be found here: 
https://thirdsun.com/help-docs/editing-menus-and-navigation/using-hidden-menus-for-shorter-urls  
NOTE: Hidden menus are handy, but shouldn’t be used for every page on your site. Hidden Menus have their 
place, but overall Troy has a good rule of thumb: It is ideal to just send people to your homepage. If whatever is 
going on isn't obvious from there, then that is a problem. 
 
To Create a Redirect 
We don’t recommend changing URLs or your menu structure, because it can break links elsewhere (on your site or 
where someone else has linked to it) but if a URL changes, i.e. on the Main Menu you swap “Our Mission” for a 
page called “Mission and History” and your old page may be linked somewhere, to avoid 404 errors you can go to 
Components > RSSeo! > Redirects. Then click “New” and put the old URL as “From” and the new URL as “To” 
and save. If the old URL is typed in or clicked on, it will redirect to the new one. 
 
To View URLs Causing 404 Errors 
This ties into the info above – if you’re changing URLs it can cause errors. We’ve tried to mitigate this as much as 
possible, but 404s can still happen. To view what URLs people are clicking and reaching errors, go to Components 
> RSSeo! > Error URLs. This will show the list of ‘bad’ URLs. Many will be from bots. We’ve tried to correct many 
already, but if you see a new URL or one that’s not on the redirect list, you can create a redirect for it to an existing 
page to avoid errors in the future. 
 
Engagebox Popup Window 
To have a popup that shows up when you enter the site (like for advertising an upcoming event) is an option 
managed in EngageBox. If you’d like to add or remove a popup or change the message or settings, you can find 
steps here: https://thirdsun.com/help-docs/engage-box-pop-ups 
 
 
If you need help, please email support@thirdsun.com. Or Visit “Help Docs” https://thirdsun.com/help-docs for 
many of these things outlined. 
 


